Cartão de Cidadão no Ubuntu 18.04

A aplicação do Cartão do Cidadão precisa de algum carinho para poder ser instalada no Ubuntu 18.04. Começa-se por descarregar a Aplicação do Cartão do Cidadão.

No Ubuntu 18.04 há uma dependência  libxerces-c3.1  que falha. Para resolver o problema, descarregam-se os pacotes *.deb  em falta e instalam-se manualmente.

Agora já se pode instalar a aplicação:

Ficam duas aplicações disponíveis. A aplicação Cartão de Cidadão e a aplicação Validação de Assinaturas Digitais.

Problemas adicionais

Para além das configurações anteriores, quando instalei as ferramntas de desenvolvimento (concretamente o cmake), o gestor de pacotes removeu o libcurl3 e instalou o libcurl4. Fiquei com a aplicação do Cartão de Cidadão, que depende de libcurl3.

Por isso, foi preciso dar mais uma martelada. Graças ao Evgeny Brazgin (a propósito do bug/1754294) há uma pacote que disponibiliza libcurl3 e  libcurl4.

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *