Cartão de Cidadão no Ubuntu 19.04

O software do Cartão de Cidadão não se consegue instalar facilmente no Ubuntu 19.04.

É preciso descarregar o pacote e modificá-lo.

Retirar a dependência qtbase-abi-5-9-5

Voltar a criar o pacote.

Pelo meio, é preciso instalar alguns pacotes, nomeadamente:

O resto pode ser instalado a partir dos repositórios.

A aplicação está renovada e mais simpática. Quando não encrava…

 

3 thoughts on “Cartão de Cidadão no Ubuntu 19.04”

  1. Viva
    Obrigado pelo seu post

    Mas será que consegue p.f. dar uma explicação com os passos mais detalhados – tentei seguir os passos elencados no post mas não consegui instalar o sftware do cartão de cidadão no ubuntu 19.04…64 bits

    obrigado

    Paulo Guedes

  2. Viva Jorge

    o problema parece estar na libssl 1.0.0 que é requerido pela app do CCidadão e no meu sistema a versão e 1.0.1…

    obrigado
    Paulo Guedes

    1. Olá Paulo,

      No meu Ubuntu 19.04 a libssl está na versão 1.1.1.

      jgr@zoe:~$ apt policy libssl1.1
      libssl1.1:
      Instalado: 1.1.1-1ubuntu2.1
      Candidato: 1.1.1-1ubuntu2.1
      Tabela de Versão:
      *** 1.1.1-1ubuntu2.1 500
      500 http://pt.archive.ubuntu.com/ubuntu cosmic-updates/main amd64 Packages
      500 http://security.ubuntu.com/ubuntu cosmic-security/main amd64 Packages
      100 /var/lib/dpkg/status
      1.1.1-1ubuntu2 500
      500 http://pt.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages

      Se é esse o problema, instala a versão atual (ou força a instalação desta versão):

      sudo apt-get install libssl1.1=1.1.1-1ubuntu2.1

Leave a Reply

Your email address will not be published. Required fields are marked *